爱查股网 www.aichagu.com 股票查询最好股票网 个股数据查询好股网 关闭本站广告
爱查股网
股票查询最好股票网 个股数据查询好股网
您的位置:爱查股网 > 股票公式 > 通达信公式
股票公式搜索:

通达信逃顶一绝指标公式

2021/4/7 19:06:13

股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR21:=REF(CLOSE,1);
VAR22:=((SMA(MAX((CLOSE - VAR21),0),6,1) / SMA(ABS((CLOSE - VAR21)),6,1)) * 100);
短期顶部:(CROSS(80,VAR22) * 160),COLORWHITE;
DRAWTEXT(CROSS(80,VAR22),150,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR21),0),7,1) / SMA(ABS((CLOSE - VAR21)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR21),0),13,1) / SMA(ABS((CLOSE - VAR21)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2:=REF(LOW,1);
VAR3:=((SMA(ABS((LOW - VAR2)),3,1) / SMA(MAX((LOW - VAR2),0),3,1)) * 100);
VAR4:=EMA(IF((CLOSE * 1.2),(VAR3 * 10),(VAR3 / 10)),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=((EMA(IF((LOW <= VAR5),((VAR4 + (VAR6 * 2)) / 2),0),3) / 618) * VAR7);
秘密吸筹:STICKLINE(VAR8,0,VAR8,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,(VAR8 * 2),6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8 * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,80,15);


爱 查股网 ww w.aichagu.com

[源码注释]通达信公式动态翻译结果
 股价趋势赋值:((3 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*100)的5日[1日权重]移动平均) - (2 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*100)的5日[1日权重]移动平均的3日[1日权重]移动平均))
底部警戒赋值:10
输出买入警戒:当满足条件(股价趋势<=10)时,在0和20位置之间画柱状线,宽度为2,0不为0则画空心柱.,线宽为2,画黄色
买入信号赋值:当满足条件股价趋势上穿底部警戒时,在0和30位置之间画柱状线,宽度为3,0不为0则画空心柱.,画白色
顶部警戒赋值:90
输出卖出警戒:当满足条件(股价趋势>=85)时,在100和80位置之间画柱状线,宽度为2,0不为0则画空心柱.,线宽为2,COLOR66FF00
输出止损出局:当满足条件顶部警戒上穿股价趋势时,在130和90位置之间画柱状线,宽度为3,0不为0则画空心柱.,线宽为5,COLORFF3300
QQQ赋值:顶部警戒上穿股价趋势
输出多方趋势线:(((7 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*30)的4日[1日权重]移动平均)- (3 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*30)的4日[1日权重]移动平均的3日[1日权重]移动平均))- (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*30)的4日[1日权重]移动平均的3日[1日权重]移动平均的2日[1日权重]移动平均),COLOR8811FF,线宽为2
主升线赋值:14
天线赋值:78.89
抄底赋值:多方趋势线上穿主升线
逃顶赋值:天线上穿多方趋势线
当满足条件抄底时,在多方趋势线位置画5号图标
当满足条件逃顶时,在110位置画6号图标
VARX赋值:((3 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*100)的5日[1日权重]移动平均)- (2 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*100)的5日[1日权重]移动平均的3日[1日权重]移动平均))
股价启动在即赋值:如果VARX上穿3,返回100,否则返回0
捕食秘密买点赋值:如果(VARX<=3),返回25,否则返回0
输出建增补仓:如果(VARX<5),返回100,否则返回0,画红色
VAR21赋值:1日前的收盘价
VAR22赋值:(((收盘价-VAR21)和0的较大值的6日[1日权重]移动平均 / (收盘价-VAR21)的绝对值的6日[1日权重]移动平均) * 100)
输出短期顶部:(80上穿VAR22 * 160),画白色
当满足条件80上穿VAR22时,在150位置书写文字,画白色
VAR31赋值:(((收盘价-VAR21)和0的较大值的7日[1日权重]移动平均 / (收盘价-VAR21)的绝对值的7日[1日权重]移动平均) * 100)
VAR41赋值:(((收盘价-VAR21)和0的较大值的13日[1日权重]移动平均 / (收盘价-VAR21)的绝对值的13日[1日权重]移动平均) * 100)
VAR51赋值:收盘价的有效数据周期数
短期底部赋值:(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)))
当满足条件100上穿短期底部时,在40位置书写文字,画棕色
VAR441赋值:((5日内最低价的最低值 = 45日内最低价的最低值) AND (收盘价 >= (开盘价 * 1.04)))
VAR442赋值:(收盘价 > ((1日前的最高价 + 1日前的最低价) / 2))
红灯赋值:(VAR441 AND VAR442)
VAR33赋值:1日前的收盘价
VAR43赋值:(((收盘价-VAR33)和0的较大值的6日[1日权重]移动平均 / (收盘价-VAR33)的绝对值的6日[1日权重]移动平均) * 100)
绿灯赋值:80上穿VAR43
VAR2赋值:1日前的最低价
VAR3赋值:(((最低价-VAR2)的绝对值的3日[1日权重]移动平均 / (最低价-VAR2)和0的较大值的3日[1日权重]移动平均) * 100)
VAR4赋值:如果(收盘价*1.2),返回(VAR3*10),否则返回(VAR3/10)的3日指数移动平均
VAR5赋值:38日内最低价的最低值
VAR6赋值:38日内VAR4的最高值
VAR7赋值:如果90日内最低价的最低值,返回1,否则返回0
VAR8赋值:((如果(最低价<=VAR5),返回((VAR4+(VAR6*2))/2),否则返回0的3日指数移动平均 / 618) * VAR7)
输出秘密吸筹:当满足条件VAR8时,在0和VAR8位置之间画柱状线,宽度为6,1不为0则画空心柱.,COLORFFFF66
XL1赋值:(最低价的2日简单移动平均 * 0.96)
XL2赋值:(最低价的26日简单移动平均 * 0.85)
XL3赋值:(((1日前的XL1 < XL2) AND (1日前的XL1 < XL1)) AND (1日前的XL1 < 2日前的XL1))
当满足条件XL3时,在0和(VAR8*2)位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF00CC
输出↑短线突击:当满足条件XL3时,在40位置画25号图标,COLORFF99CC
当满足条件红灯时,在1.1位置画9号图标
当满足条件绿灯时,在80位置画15号图标

爱 查股网 ww w.aichagu.com

股票公式推荐
在线查股
个股查股导航:股票行情查询 DDX在线查询 超赢数据查询 资金流向 千股千评 个股最新消息 大小非解禁 十大股东查询 分红配股查询 业绩预告查询
天宇股份 300702+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
立方制药 003020+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
王子新材 002735+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
新华网 603888+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
禾丰股份 603609+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
京东方A 000725+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
恒宝股份 002104+1.56% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
北鼎股份 300824+1.55% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
奥雅设计 300949+1.54% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
*ST安通 600179+1.54% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
商务合作:在线客服
爱查股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。粤ICP备17111814号-1
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)