爱查股网 www.aichagu.com 股票查询最好股票网 个股数据查询好股网 关闭本站广告
爱查股网
股票查询最好股票网 个股数据查询好股网
您的位置:爱查股网 > 股票公式 > 通达信公式
股票公式搜索:

通达信直观基本面指标公式

2021/4/6 18:22:45

DRAWTEXT_FIX(1,0.1,0.01,1,'股票名称:'),COLORRED;
DRAWTEXT_FIX(1,0.15,0.01,1,STKNAME),COLORYELLOW;
品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
{股总市值:=ROUND(FINANCE(41)/100000000);}
流通盘:=(CAPITAL/1000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.1,0.15,1,'品种类型:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.25,1,'所属板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.35,1,'上市天数:'),COLORYELLOW;
{DRAWTEXT_FIX(1,0.1,0.45,1,'股总市值:'),COLORYELLOW;}
DRAWTEXT_FIX(1,0.1,0.45,1,'流通盘:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.55,1,'流通市值:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.65,1,'股东人数:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.75,1,'人均持股:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0.25,1,HYBLOCK),COLORLIGREEN;
DRAWNUMBER_FIX(1,0.15,0.35,1,上市天数),COLORWHITE;
DRAWNUMBER_FIX(1,0.15,0.45,1,流通盘),COLORWHITE;
DRAWNUMBER_FIX(1,0.15,0.55,1,流通市值),COLORWHITE;
DRAWNUMBER_FIX(1,0.15,0.65,1,股东人数),COLORWHITE;
DRAWNUMBER_FIX(1,0.15,0.75,1,人均持股),COLORWHITE;
DRAWTEXT_FIX(品种类型=1,0.15,0.15,1,'沪 深 A 股'),COLORMAGENTA;
DRAWTEXT_FIX(品种类型=2,0.15,0.15,1,' 中 小 板'),COLORMAGENTA;
DRAWTEXT_FIX(品种类型=3,0.15,0.15,1,' 创 业 板'),COLORMAGENTA;
DRAWTEXT_FIX(1,0.18,0.35,1,'天'),COLORCYAN;
DRAWTEXT_FIX(1,0.18,0.45,1,'亿元'),COLORCYAN;
DRAWTEXT_FIX(1,0.18,0.55,1,'亿元'),COLORCYAN;
DRAWTEXT_FIX(1,0.18,0.65,1,'人'),COLORCYAN;
DRAWTEXT_FIX(1,0.18,0.75,1,'股'),COLORCYAN;
DRAWTEXT_FIX(1,0.326,0.01,1,'业绩指标(如下):'),COLORRED;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
销售毛利率:=CONST(((FINANCE(20)-FINANCE(21))/FINANCE(20)*100));
净利润比率:=(FINANCE(30)/FINANCE(20)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
优质资产率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));{理论上越大越好但不同行业有不同标准};
现金负债比:=(FINANCE(25)/FINANCE(15));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
净利同增率:=FINANCE(43);
总市值(亿):FINANCE(41)/100000000,NODRAW; 净资产:FINANCE(34),NODRAW;
销净利率:FINVALUE(199),NODRAW; 净利润(万):FINANCE(30)/10000,NODRAW; 净利增长率:=FINVALUE(184),NODRAW;
DRAWTEXT_FIX(1,0.30,0.15,1,'净资收益率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.30,0.25,1,'销售毛利率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.30,0.35,1,'净利润率 :'),COLORYELLOW;
DRAWTEXT_FIX(1,0.30,0.45,1,'主营利润率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.30,0.55,1,'优质资产率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.30,0.65,1,'现金负债比:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.30,0.75,1,'净利同增率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.35,0.15,1,净资收益率),COLORWHITE;
DRAWNUMBER_FIX(1,0.35,0.25,1,销售毛利率),COLORWHITE;
DRAWNUMBER_FIX(1,0.35,0.35,1,净利润比率),COLORWHITE;
DRAWNUMBER_FIX(1,0.35,0.45,1,主营利润率),COLORWHITE;
DRAWNUMBER_FIX(1,0.35,0.55,1,优质资产率),COLORWHITE;
DRAWNUMBER_FIX(1,0.35,0.65,1,现金负债比),COLORWHITE;
DRAWNUMBER_FIX(1,0.35,0.75,1,净利同增率),COLORWHITE;
DRAWTEXT_FIX(1,0.478,0.01,1,'财务指标(如下):'),COLORRED;
PB:=CONST(DYNAINFO(7) / FINANCE(34));
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
{每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));}
每股收益:=CONST(FINANCE(38));{最近一期}
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
PE:=CONST(C/FINANCE(33));
{毛利率:=CONST(((FINANCE(20)-FINANCE(21))/FINANCE(20)*100));}
DRAWTEXT_FIX(1,0.45,0.15,1,'市净率:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.45,0.25,1,'市销率:'),COLORYELLOW;
{DRAWTEXT_FIX(1,0.45,0.35,1,'每股收益季:'),COLORYELLOW;}
{DRAWTEXT_FIX(1,0.45,0.35,1,'毛利率 :'),COLORYELLOW;}
DRAWTEXT_FIX(1,0.45,0.45,1,'每股收益:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.45,0.55,1,'每股现金流:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.45,0.65,1,'每股未分配:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.45,0.75,1,'每股公积金:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.45,0.35,1,'市盈率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.50,0.15,1,PB),COLORWHITE;
DRAWNUMBER_FIX(1,0.50,0.25,1,市销率),COLORWHITE;
{DRAWNUMBER_FIX(1,0.50,0.35,1,每股收益季),COLORWHITE;}
DRAWNUMBER_FIX(1,0.50,0.45,1,每股收益),COLORWHITE;
DRAWNUMBER_FIX(1,0.50,0.55,1,每股现金流),COLORWHITE;
DRAWNUMBER_FIX(1,0.50,0.65,1,每股未分配),COLORWHITE;
DRAWNUMBER_FIX(1,0.50,0.75,1,每股公积金),COLORWHITE;
DRAWNUMBER_FIX(1,0.50,0.35,1,PE),COLORWHITE;
{DRAWNUMBER_FIX(1,0.50,0.85,1,毛利率),COLORWHITE;}
主力筹码估算:=EMA(WINNER(CLOSE)*70,3),NODRAW,LINETHICK0;
散户筹码估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
散户套牢比率:=散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
主力控盘比率:=主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.22,0.93,0,'■ 主力筹码估算:'),COLORFEFE05;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.36,0.93,0,' %'),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.32,0.93,0,主力筹码估算),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.03,0.93,0,'■ 主力控盘比率:'),COLORFEFE05;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.17,0.93,0,' %'),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.13,0.93,0,主力控盘比率),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.42,0.93,0,'■ 散户筹码估算:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.56,0.93,0,' %'),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.52,0.93,0,散户筹码估算),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.42,0.87,0,'■ 散户套牢比率:'),COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.56,0.87,0,' %'),COLOR00FF00;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.52,0.87,0,散户套牢比率),COLOR00FF00;
{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
LC:=REF(CLOSE,1);
WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
获利筹码:=CONST(WINNER(C)*100);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:=(IF(SAT>1,1,SAT)*100);
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃:=(WRSI-WR10);
活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2));
DRAWTEXT_FIX(1,0.95,0.01,1,STRCAT(STRCAT('量能饱和: ',CON2STR(量能饱和,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.95,0.08,1,STRCAT(STRCAT('活跃度比: ',CON2STR(活跃度比,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.95,0.15,1,STRCAT(STRCAT('获利筹码: ',CON2STR(获利筹码,2)),'%')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.96,0.01,1,'大盘趋势:'),COLORRED;
DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.16,1,'∧向上∧'),COLORRED;
{DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.11,1,'∧∧∧∧'),COLORRED;}
{DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.16,1,'∨向下∨'),COLORGREEN;
{DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.11,1,'∨∨∨∨'),COLORGREEN;}
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.63,0.93,0,'数据日期: '),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.80,0.93,0,' 财报更新第:'),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.90,0.93,0,FINANCE(37)),,COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.70,0.93,0,MACHINEDATE+19000000),COLORMAGENTA;
{-----优秀-------}
ER1:=净资收益率>=13.58;
ER2:=主营利润率>=22.4;
ER5:=净利润比率>=19.42;
SAX1:=每股收益>=0.175;
SAX4:=每股未分配>=2.57;
SAX5:=每股公积金>=3.53;
DP3:=销售毛利率>=49.13;
ZL:=IF((EMA(WINNER(CLOSE)*70,3))>41 AND ISLASTBAR,1,0);
优秀:=ER1 AND ER2 AND ER5 AND SAX1
AND SAX4 AND SAX5 AND DP3 AND ZL ;
DRAWTEXT_FIX(1,0.70,0.01,1,'基本面评估:'),COLORRED;
DRAWTEXT_FIX(优秀 AND ISLASTBAR,0.75,0.01,1,'[优秀]'),COLORYELLOW;
{较好}
ER12:=净资收益率<13.59 AND 净资收益率>6.23;
ER22:=主营利润率>=8.34;
ER52:=净利润比率>=7.31;
SAX12:= 每股收益>=0.061;
SAX42:=每股未分配>=1.185;
SAX52:=每股公积金>1.62;
DP32:=销售毛利率>=28.68;
ZL1:=IF((EMA(WINNER(CLOSE)*70,3))>=11.26 AND ISLASTBAR,1,0);
{ER42:=主营业增长率>1; SAX22:=每股净资产>0.2; DP42:=换手率>0.5; WMF12:=量比>0.5;}
较好:=ER12 AND ER22 AND ER52 AND SAX12
AND SAX42 AND SAX52 AND DP32 AND ZL1;
DRAWTEXT_FIX(较好 AND ISLASTBAR,0.75,0.01,1,'[良好]'),COLORYELLOW;
{指标偏低}
ER偏低:=净资收益率<=0.27;
ER2偏低:=主营利润率<=-1.27;
ER3偏低:=净利润比率<=0.34;
SAX偏低:=每股收益<=0.002;
SAX2偏低:=每股未分配<=0.26;
SAX3偏低:=每股公积金<=0.39;
DP偏低:=销售毛利率<=4.2;{排名后100}
ZL偏低:=IF(((EMA(WINNER(CLOSE)*70,3))<2.81 AND ISLASTBAR),1,0);
偏低:=IF((ER偏低 OR ER2偏低 OR ER3偏低 OR SAX偏低
OR SAX2偏低 OR SAX3偏低 OR DP偏低 OR ZL偏低) AND ISLASTBAR=1,1,0) ;
{一般};
一般:=IF((较好!=1 AND 优秀!=1 AND ZL偏低!=1 AND ISLASTBAR=1),1,0);
DRAWTEXT_FIX(一般 AND ISLASTBAR=1,0.75,0.01,1,'[一般]'),COLORYELLOW;
坏账:=FINVALUE(11)/(FINANCE(19));
投资:=FINVALUE(35)/(FINANCE(19));
负债:=FINVALUE(210)/100;
存货:=FINVALUE(17)/(FINANCE(19));
合计:=(坏账+投资+负债+存货)/4,COLORBROWN,LINETHICK2;
DRAWTEXT_FIX(ISLASTBAR,0.70,0.26,0,STRCAT('坏账评估:',CON2STR(坏账,3))),COLORLIGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.82,0.26,0,STRCAT('坏账等级:',IF(坏账<0.15 AND 坏账>=0 ,'低',IF(坏账<0.35 AND 坏账>=0.15 ,'正常',IF(坏账<0.45 AND 坏账>=0.35 ,'中',IF(坏账>=0.45 OR 坏账<0 ,'高','__')))))),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.70,0.36,0,STRCAT('投资评估:',CON2STR(投资,3))),COLORLIGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.70,0.46,0,STRCAT('负债评估:',CON2STR(负债,3))),COLORLIGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.82,0.46,0,STRCAT('负债等级:',IF(负债<0.25 AND 负债>=0 ,'低',IF(负债<0.45 AND 负债>=0.25,'正常',IF(负债<0.65 AND 负债>=0.45 ,'中',IF(负债>=0.65 OR 负债<0 ,'高','__')))))),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.70,0.56,0,STRCAT('存货评估:',CON2STR(存货,3))),COLORLIGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.70,0.66,0,STRCAT('综合评估:',CON2STR(合计,3)))COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.78,0.76,0,STRCAT('财务风险等级:',IF(合计<0.3 AND 合计>=0 ,'低风险',IF(合计<0.5 AND 合计>=0.3 ,'中风险',IF(合计>=0.5 OR 合计<0 ,'高风险','__'))))),,COLORGREEN;
市盈率:=DYNAINFO(39);
市净率:=FINANCE(34)/C;
每股收益1:=FINANCE(33);
资产报酬率:=FINANCE(29)/FINANCE(10)*100;
股本报酬率:=FINANCE(29)/FINANCE(1)*100;
净值报酬率:=FINANCE(29)/FINANCE(19)*100;
营业纯益率:=FINANCE(29)/FINANCE(20)*100;
主营业务利润率:=FINANCE(21)/FINANCE(20)*100;
负债比率:=(FINANCE(15)+FINANCE(16))/FINANCE(10)*100;
存货周转率:=(FINANCE(20)-FINANCE(23))/FINANCE(27);
固定资产周转率:=FINANCE(20)/FINANCE(12);
市盈率评分:=IF(市盈率<=20 AND 市盈率>0,10,IF(市盈率<=40 AND 市盈率>20,9,
IF(市盈率<=60 AND 市盈率>40,8,IF(市盈率<=80 AND 市盈率>60,7,
IF(市盈率<=100 AND 市盈率>80,6,IF(市盈率<=130 AND 市盈率>100,5,
IF(市盈率<=160 AND 市盈率>130,4,IF(市盈率<=190 AND 市盈率>160,3,
IF(市盈率<=220 AND 市盈率>190,2,IF(市盈率<=250 AND 市盈率>220,1,0))))))))));
市净率评分:=IF(市净率>=1,10,IF(市净率<=1 AND 市净率>=0.9,9,
IF(市净率<=0.9 AND 市净率>0.8,8,IF(市净率<=0.8 AND 市净率>0.7,7,
IF(市净率<=0.7 AND 市净率>0.6,6,IF(市净率<=0.6 AND 市净率>0.5,5,
IF(市净率<=0.5 AND 市净率>0.4,4,IF(市净率<=0.4 AND 市净率>0.3,3,
IF(市净率<=0.3 AND 市净率>0.2,2,IF(市净率<=0.2 AND 市净率>0,1,0))))))))));
每股收益评分:=IF(每股收益>=2.7,10,IF(每股收益<2.7 AND 每股收益>=2.4,9,
IF(每股收益1<2.4 AND 每股收益1>=2.1,8,IF(每股收益1<2.1 AND 每股收益1>=1.8,7,
IF(每股收益1<1.8 AND 每股收益1>=1.5,6,IF(每股收益1<1.5 AND 每股收益1>=1.2,5,
IF(每股收益1<1.2 AND 每股收益1>=0.9,4,IF(每股收益1<0.9 AND 每股收益1>=0.6,3,
IF(每股收益1<0.6 AND 每股收益1>=0.3,2,IF(每股收益1<0.3 AND 每股收益1>=0,1,0))))))))));
资产报酬率评分:=IF(资产报酬率>=27,10,IF(资产报酬率<27 AND 资产报酬率>=24,9,
IF(资产报酬率<24 AND 资产报酬率>=21,8,IF(资产报酬率<21 AND 资产报酬率>=18,7,
IF(资产报酬率<18 AND 资产报酬率>=15,6,IF(资产报酬率<15 AND 资产报酬率>=12,5,
IF(资产报酬率<12 AND 资产报酬率>9,4,IF(资产报酬率<9 AND 资产报酬率>6,3,
IF(资产报酬率<6 AND 资产报酬率>=3,2,IF(资产报酬率<3 AND 资产报酬率>0,1,0))))))))));
股本报酬率评分:=IF(股本报酬率>=135,10,IF(股本报酬率<135 AND 股本报酬率>120,9,
IF(股本报酬率<120 AND 股本报酬率>=105,8,IF(股本报酬率<105 AND 股本报酬率>90,7,
IF(股本报酬率<90 AND 股本报酬率>=75,6,IF(股本报酬率<75 AND 股本报酬率>60,5,
IF(股本报酬率<60 AND 股本报酬率>=45,4,IF(股本报酬率<45 AND 股本报酬率>30,3,
IF(股本报酬率<30 AND 股本报酬率>=15,2,IF(股本报酬率<15 AND 股本报酬率>0,1,0))))))))));
净值报酬率评分:=IF(净值报酬率>=100,10,IF(净值报酬率<100 AND 净值报酬率>80,9,
IF(净值报酬率<80 AND 净值报酬率>=70,8,IF(净值报酬率<70 AND 净值报酬率>60,7,
IF(净值报酬率<60 AND 净值报酬率>=50,6,IF(净值报酬率<50 AND 净值报酬率>40,5,
IF(净值报酬率<40 AND 净值报酬率>=30,4,IF(净值报酬率<30 AND 净值报酬率>20,3,
IF(净值报酬率<20 AND 净值报酬率>=10,2,IF(净值报酬率<10 AND 净值报酬率>=0,1,0))))))))));
营业纯益率评分:=IF(营业纯益率>=60,10,IF(营业纯益率<60 AND 营业纯益率>=50,9,
IF(营业纯益率<50 AND 营业纯益率>=40,8,IF(营业纯益率<40 AND 营业纯益率>=30,7,
IF(营业纯益率<30 AND 营业纯益率>=20,6,IF(营业纯益率<20 AND 营业纯益率>15,5,
IF(营业纯益率<15 AND 营业纯益率>=10,4,IF(营业纯益率<10 AND 营业纯益率>5,3,
IF(营业纯益率<5 AND 营业纯益率>=3,2,IF(营业纯益率<3 AND 营业纯益率>=0,1,0))))))))));
主营利润率评分:=IF(主营业务利润率>=60,10,IF(主营业务利润率<60 AND 主营业务利润率>50,9,
IF(主营业务利润率<50 AND 主营业务利润率>=45,8,IF(主营业务利润率<45 AND 主营业务利润率>=40,7,
IF(主营业务利润率<40 AND 主营业务利润率>=35,6,IF(主营业务利润率<35 AND 主营业务利润率>=30,5,
IF(主营业务利润率<30 AND 主营业务利润率>=25,4,IF(主营业务利润率<25 AND 主营业务利润率>=20,3,
IF(主营业务利润率<20 AND 主营业务利润率>=10,2,IF(主营业务利润率<10 AND 主营业务利润率>=0,1,0))))))))));
负债比率评分:=IF(负债比率<=0,10,IF(负债比率>0 AND 负债比率<10,9,
IF(负债比率>10 AND 负债比率<=20,8,IF(负债比率>20 AND 负债比率<=30,7,
IF(负债比率>30 AND 负债比率<=40,6,IF(负债比率>40 AND 负债比率<=50,5,
IF(负债比率>50 AND 负债比率<=60,4,IF(负债比率>60 AND 负债比率<=70,3,
IF(负债比率>70 AND 负债比率<=80,2,IF(负债比率>80 AND 负债比率<=100,1,0))))))))));
存货周转率评分:=IF(存货周转率>=80,5,IF(存货周转率<80 AND 存货周转率>=60,4,
IF(存货周转率<60 AND 存货周转率>=40,3,IF(存货周转率<40 AND 存货周转率>=20,2,
IF(存货周转率<20 AND 存货周转率>=0,1,0)))));
资产周转率评分:=IF(固定资产周转率>=20,5,IF(固定资产周转率<20 AND 固定资产周转率>=15,4,
IF(固定资产周转率<15 AND 固定资产周转率>=10,3,IF(固定资产周转率<10 AND 固定资产周转率>=5,2,
IF(固定资产周转率<5 AND 固定资产周转率>=0,1,0)))));
估值评分:=市盈率评分+市净率评分+每股收益评分,COLORRED,NODRAW;
收益评分:=资产报酬率评分+股本报酬率评分+净值报酬率评分+营业纯益率评分+主营利润率评分,NODRAW;
资产评分:=负债比率评分+存货周转率评分+资产周转率评分,COLORYELLOW,NODRAW;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.26,0,STRCAT('估值评分:',CON2STR(估值评分,3))),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.36,0,STRCAT('收益评分:',CON2STR(收益评分,3))),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.46,0,STRCAT('资产评分:',CON2STR(资产评分,3))),COLORLIRED;
评分:=估值评分+收益评分+资产评分;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.56,0,STRCAT('总评分:',CON2STR(评分,3))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.55,0.66,0,STRCAT('经营状况等级:',IF(评分<40 AND 评分>=30 ,'(合格)',IF(评分<50 AND 评分>=40 ,'(良好)',IF(评分<30 AND 评分>=0 ,'(不合格)',IF(评分>=50,'(优秀)','__')))))),COLORRED;
DRAWTEXT_FIX(1,0.75,0.76,1,'说明:估值评分没显示表示业绩亏损'),COLORRED;
DRAWTEXT_FIX(1,0.78,0.85,1,'说明:资产评分没显示表示为金融类行业'),COLORRED;
DRAWTEXT_FIX(1,0.75,0.10,1,'备注:需下载专业财务数据(盘后)'),COLORRED;


爱查 股网 www.ai chagu.com

[源码注释]通达信公式动态翻译结果
 当满足条件1时,在横轴0.1纵轴0.01位置书写文字,画红色
当满足条件1时,在横轴0.15纵轴0.01位置书写文字,画黄色
品种类型赋值:沪深品种类型
所属板块赋值:所属行业(字串)
上市天数赋值:上市的天数
流通盘赋值:(当前流通股本(手)/1000000)
流通市值赋值:对流通市值/100000000(进行)四舍五入
股东人数赋值:股东人数(户)
人均持股赋值:对流通股本(股)/股东人数(户)(进行)四舍五入
当满足条件1时,在横轴0.1纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.1纵轴0.25位置书写文字,画黄色
当满足条件1时,在横轴0.1纵轴0.35位置书写文字,画黄色
当满足条件1时,在横轴0.1纵轴0.45位置书写文字,画黄色
当满足条件1时,在横轴0.1纵轴0.55位置书写文字,画黄色
当满足条件1时,在横轴0.1纵轴0.65位置书写文字,画黄色
当满足条件1时,在横轴0.1纵轴0.75位置书写文字,画黄色
当满足条件1时,在横轴0.15纵轴0.25位置书写文字,画淡绿色
当满足条件1时,在横轴0.15纵轴0.35位置书写数字,画白色
当满足条件1时,在横轴0.15纵轴0.45位置书写数字,画白色
当满足条件1时,在横轴0.15纵轴0.55位置书写数字,画白色
当满足条件1时,在横轴0.15纵轴0.65位置书写数字,画白色
当满足条件1时,在横轴0.15纵轴0.75位置书写数字,画白色
当满足条件品种类型=1时,在横轴0.15纵轴0.15位置书写文字,画洋红色
当满足条件品种类型=2时,在横轴0.15纵轴0.15位置书写文字,画洋红色
当满足条件品种类型=3时,在横轴0.15纵轴0.15位置书写文字,画洋红色
当满足条件1时,在横轴0.18纵轴0.35位置书写文字,画青色
当满足条件1时,在横轴0.18纵轴0.45位置书写文字,画青色
当满足条件1时,在横轴0.18纵轴0.55位置书写文字,画青色
当满足条件1时,在横轴0.18纵轴0.65位置书写文字,画青色
当满足条件1时,在横轴0.18纵轴0.75位置书写文字,画青色
当满足条件1时,在横轴0.326纵轴0.01位置书写文字,画红色
净资收益率赋值:(每股收益(全年折算)/每股净资产*100)
销售毛利率赋值:((营业收入-营业成本)/营业收入*100)的最后一日取值设为常数
净利润比率赋值:(净利润/营业收入*100)
主营利润率赋值:(营业利润/营业收入*100)
优质资产率赋值:((股东权益(净资产)-应收帐款-存货)/股东权益(净资产))

现金负债比赋值:(经营现金流量/流动负债)

净利同增率赋值:利润同比%
输出总市值(亿):AB股总市值/100000000,NODRAW
输出 净资产:每股净资产,NODRAW
输出销净利率:引用199号ID的序列数据,NODRAW
输出 净利润(万):净利润/10000,NODRAW
净利增长率赋值:引用184号ID的序列数据,NODRAW
当满足条件1时,在横轴0.30纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.30纵轴0.25位置书写文字,画黄色
当满足条件1时,在横轴0.30纵轴0.35位置书写文字,画黄色
当满足条件1时,在横轴0.30纵轴0.45位置书写文字,画黄色
当满足条件1时,在横轴0.30纵轴0.55位置书写文字,画黄色
当满足条件1时,在横轴0.30纵轴0.65位置书写文字,画黄色
当满足条件1时,在横轴0.30纵轴0.75位置书写文字,画黄色
当满足条件1时,在横轴0.35纵轴0.15位置书写数字,画白色
当满足条件1时,在横轴0.35纵轴0.25位置书写数字,画白色
当满足条件1时,在横轴0.35纵轴0.35位置书写数字,画白色
当满足条件1时,在横轴0.35纵轴0.45位置书写数字,画白色
当满足条件1时,在横轴0.35纵轴0.55位置书写数字,画白色
当满足条件1时,在横轴0.35纵轴0.65位置书写数字,画白色
当满足条件1时,在横轴0.35纵轴0.75位置书写数字,画白色
当满足条件1时,在横轴0.478纵轴0.01位置书写文字,画红色
PB赋值:现价/每股净资产的最后一日取值设为常数
市销率赋值:总股本(股)*现价/营业收入的最后一日取值设为常数
每股收益赋值:每股收益(最近一期)的最后一日取值设为常数
每股现金流赋值:(经营现金流量/总股本(股))的最后一日取值设为常数
每股未分配赋值:每股未分配利润的最后一日取值设为常数
每股公积金赋值:每股公积金的最后一日取值设为常数
PE赋值:收盘价/每股收益(全年折算)的最后一日取值设为常数
当满足条件1时,在横轴0.45纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.45纵轴0.25位置书写文字,画黄色
当满足条件1时,在横轴0.45纵轴0.45位置书写文字,画黄色
当满足条件1时,在横轴0.45纵轴0.55位置书写文字,画黄色
当满足条件1时,在横轴0.45纵轴0.65位置书写文字,画黄色
当满足条件1时,在横轴0.45纵轴0.75位置书写文字,画黄色
当满足条件1时,在横轴0.45纵轴0.35位置书写文字,画黄色
当满足条件1时,在横轴0.50纵轴0.15位置书写数字,画白色
当满足条件1时,在横轴0.50纵轴0.25位置书写数字,画白色
当满足条件1时,在横轴0.50纵轴0.45位置书写数字,画白色
当满足条件1时,在横轴0.50纵轴0.55位置书写数字,画白色
当满足条件1时,在横轴0.50纵轴0.65位置书写数字,画白色
当满足条件1时,在横轴0.50纵轴0.75位置书写数字,画白色
当满足条件1时,在横轴0.50纵轴0.35位置书写数字,画白色
主力筹码估算赋值:以收盘价计算的获利盘比例*70的3日指数移动平均,NODRAW,线宽为0
散户筹码估算赋值:(以收盘价*1.1计算的获利盘比例-以收盘价*0.9计算的获利盘比例)*80的3日指数移动平均,NODRAW
散户套牢比率赋值:散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW
主力控盘比率赋值:主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW
当满足条件到最后交易的周期=1时,在横轴0.22纵轴0.93位置书写文字,COLORFEFE05
当满足条件到最后交易的周期=1时,在横轴0.36纵轴0.93位置书写文字,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.32纵轴0.93位置书写数字,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.03纵轴0.93位置书写文字,COLORFEFE05
当满足条件到最后交易的周期=1时,在横轴0.17纵轴0.93位置书写文字,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.13纵轴0.93位置书写数字,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.42纵轴0.93位置书写文字,画红色
当满足条件到最后交易的周期=1时,在横轴0.56纵轴0.93位置书写文字,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.52纵轴0.93位置书写数字,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.42纵轴0.87位置书写文字,COLOR00FF00
当满足条件到最后交易的周期=1时,在横轴0.56纵轴0.87位置书写文字,COLOR00FF00
当满足条件到最后交易的周期=1时,在横轴0.52纵轴0.87位置书写数字,COLOR00FF00
X1赋值:(流动资产-流动负债)/总资产*1.2
X2赋值:(未分配利润+资本公积金)/总资产*1.4
X3赋值:营业利润/总资产*3.3
X4赋值:股东权益(净资产)/流动负债*0.6
X5赋值:营业收入/流动负债*0.999
LC赋值:1日前的收盘价
WRSI赋值:收盘价-LC和0的较大值的5日[1日权重]移动平均/收盘价-LC的绝对值的5日[1日权重]移动平均*100
获利筹码赋值:以收盘价计算的获利盘比例*100的最后一日取值设为常数
SAT赋值:(成交额(元)/收盘价)/(20日内成交额(元)的最高值/20日内收盘价的最高值)
量能饱和赋值:(如果SAT>1,返回1,否则返回SAT*100)
WR10赋值:(3日内最高价的最高值-收盘价)/(3日内最高价的最高值-3日内最低价的最低值)*100
活跃赋值:(WRSI-WR10)
活跃度比赋值:如果活跃>=0,返回(活跃+100)/2,否则返回100-(活跃-100)/2的绝对值
当满足条件1时,在横轴0.95纵轴0.01位置书写文字,画黄色
当满足条件1时,在横轴0.95纵轴0.08位置书写文字,画黄色
当满足条件1时,在横轴0.95纵轴0.15位置书写文字,画黄色
当满足条件到最后交易的周期=1时,在横轴0.63纵轴0.93位置书写文字,画红色
当满足条件到最后交易的周期=1时,在横轴0.80纵轴0.93位置书写文字,画红色
当满足条件到最后交易的周期=1时,在横轴0.90纵轴0.93位置书写数字,,画洋红色
当满足条件到最后交易的周期=1时,在横轴0.70纵轴0.93位置书写数字,画洋红色
ER1赋值:净资收益率>=13.58
ER2赋值:主营利润率>=22.4
ER5赋值:净利润比率>=19.42
SAX1赋值:每股收益>=0.175
SAX4赋值:每股未分配>=2.57
SAX5赋值:每股公积金>=3.53
DP3赋值:销售毛利率>=49.13
ZL赋值:如果(以收盘价计算的获利盘比例*70的3日指数移动平均)>41ANDISLASTBAR,返回1,否则返回0
优秀赋值:ER1 AND ER2 AND ER5 AND SAX1AND SAX4 AND SAX5 AND DP3 AND ZL 
当满足条件1时,在横轴0.70纵轴0.01位置书写文字,画红色
当满足条件优秀ANDISLASTBAR时,在横轴0.75纵轴0.01位置书写文字,画黄色
ER12赋值:净资收益率<13.59 AND 净资收益率>6.23
ER22赋值:主营利润率>=8.34
ER52赋值:净利润比率>=7.31
SAX12赋值: 每股收益>=0.061
SAX42赋值:每股未分配>=1.185
SAX52赋值:每股公积金>1.62
DP32赋值:销售毛利率>=28.68
ZL1赋值:如果(以收盘价计算的获利盘比例*70的3日指数移动平均)>=11.26ANDISLASTBAR,返回1,否则返回0
较好赋值:ER12 AND ER22 AND ER52 AND SAX12AND SAX42 AND SAX52 AND DP32 AND ZL1
当满足条件较好ANDISLASTBAR时,在横轴0.75纵轴0.01位置书写文字,画黄色
ER偏低赋值:净资收益率<=0.27
ER2偏低赋值:主营利润率<=-1.27
ER3偏低赋值:净利润比率<=0.34
SAX偏低赋值:每股收益<=0.002
SAX2偏低赋值:每股未分配<=0.26
SAX3偏低赋值:每股公积金<=0.39
DP偏低赋值:销售毛利率<=4.2
ZL偏低赋值:如果((以收盘价计算的获利盘比例*70的3日指数移动平均)<2.81ANDISLASTBAR),返回1,否则返回0
偏低赋值:如果(ER偏低ORER2偏低ORER3偏低ORSAX偏低ORSAX2偏低ORSAX3偏低ORDP偏低ORZL偏低)ANDISLASTBAR=1,返回1,否则返回0 

一般赋值:如果(较好不等于1AND优秀不等于1ANDZL偏低不等于1ANDISLASTBAR=1),返回1,否则返回0
当满足条件一般ANDISLASTBAR=1时,在横轴0.75纵轴0.01位置书写文字,画黄色
坏账赋值:引用11号ID的序列数据/(股东权益(净资产))
投资赋值:引用35号ID的序列数据/(股东权益(净资产))
负债赋值:引用210号ID的序列数据/100
存货赋值:引用17号ID的序列数据/(股东权益(净资产))
合计赋值:(坏账+投资+负债+存货)/4,画棕色,线宽为2
当满足条件是否最后一个周期时,在横轴0.70纵轴0.26位置书写文字,画淡绿色
当满足条件是否最后一个周期时,在横轴0.82纵轴0.26位置书写文字,画洋红色
当满足条件是否最后一个周期时,在横轴0.70纵轴0.36位置书写文字,画淡绿色
当满足条件是否最后一个周期时,在横轴0.70纵轴0.46位置书写文字,画淡绿色
当满足条件是否最后一个周期时,在横轴0.82纵轴0.46位置书写文字,画洋红色
当满足条件是否最后一个周期时,在横轴0.70纵轴0.56位置书写文字,画淡绿色
当满足条件是否最后一个周期时,在横轴0.70纵轴0.66位置书写文字画绿色
当满足条件是否最后一个周期时,在横轴0.78纵轴0.76位置书写文字,,画绿色
市盈率赋值:市盈(动)
市净率赋值:每股净资产/收盘价
每股收益1赋值:每股收益(全年折算)
资产报酬率赋值:FINANCE(29)/总资产*100
股本报酬率赋值:FINANCE(29)/总股本(股)*100
净值报酬率赋值:FINANCE(29)/股东权益(净资产)*100
营业纯益率赋值:FINANCE(29)/营业收入*100
主营业务利润率赋值:营业成本/营业收入*100
负债比率赋值:(流动负债+少数股东权益)/总资产*100
存货周转率赋值:(营业收入-营业利润)/存货
固定资产周转率赋值:营业收入/固定资产
市盈率评分赋值:如果市盈率<=20AND市盈率>0,返回10,否则返回如果市盈率<=40AND市盈率>20,返回9,否则返回如果市盈率<=60AND市盈率>40,返回8,否则返回如果市盈率<=80AND市盈率>60,返回7,否则返回如果市盈率<=100AND市盈率>80,返回6,否则返回如果市盈率<=130AND市盈率>100,返回5,否则返回如果市盈率<=160AN,返回?,否则返回?
市净率评分赋值:如果市净率>=1,返回10,否则返回如果市净率<=1AND市净率>=0.9,返回9,否则返回如果市净率<=0.9AND市净率>0.8,返回8,否则返回如果市净率<=0.8AND市净率>0.7,返回7,否则返回如果市净率<=0.7AND市净率>0.6,返回6,否则返回如果市净率<=0.6AND市净率>0.5,返回5,否则返回如果市净率<,返回?,否则返回?
每股收益评分赋值:如果每股收益>=2.7,返回10,否则返回如果每股收益<2.7AND每股收益>=2.4,返回9,否则返回如果每股收益1<2.4AND每股收益1>=2.1,返回8,否则返回如果每股收益1<2.1AND每股收益1>=1.8,返回7,否则返回如果每股收益1<1.8AND每股收益1>=1.5,返回6,否则返回如果每股收益1<1.5A,返回?,否则返回?
资产报酬率评分赋值:如果资产报酬率>=27,返回10,否则返回如果资产报酬率<27AND资产报酬率>=24,返回9,否则返回如果资产报酬率<24AND资产报酬率>=21,返回8,否则返回如果资产报酬率<21AND资产报酬率>=18,返回7,否则返回如果资产报酬率<18AND资产报酬率>=15,返回6,否则返回如果资产报酬率<1,返回?,否则返回?
股本报酬率评分赋值:如果股本报酬率>=135,返回10,否则返回如果股本报酬率<135AND股本报酬率>120,返回9,否则返回如果股本报酬率<120AND股本报酬率>=105,返回8,否则返回如果股本报酬率<105AND股本报酬率>90,返回7,否则返回如果股本报酬率<90AND股本报酬率>=75,返回6,否则返回如果股本报酬?返回?,否则返回?
净值报酬率评分赋值:如果净值报酬率>=100,返回10,否则返回如果净值报酬率<100AND净值报酬率>80,返回9,否则返回如果净值报酬率<80AND净值报酬率>=70,返回8,否则返回如果净值报酬率<70AND净值报酬率>60,返回7,否则返回如果净值报酬率<60AND净值报酬率>=50,返回6,否则返回如果净值报酬率<50,返回?,否则返回?
营业纯益率评分赋值:如果营业纯益率>=60,返回10,否则返回如果营业纯益率<60AND营业纯益率>=50,返回9,否则返回如果营业纯益率<50AND营业纯益率>=40,返回8,否则返回如果营业纯益率<40AND营业纯益率>=30,返回7,否则返回如果营业纯益率<30AND营业纯益率>=20,返回6,否则返回如果营业纯益率<2,返回?,否则返回?
主营利润率评分赋值:如果主营业务利润率>=60,返回10,否则返回如果主营业务利润率<60AND主营业务利润率>50,返回9,否则返回如果主营业务利润率<50AND主营业务利润率>=45,返回8,否则返回如果主营业务利润率<45AND主营业务利润率>=40,返回7,否则返回如果主营业务利润率<40AND主营?返回?,否则返回?
负债比率评分赋值:如果负债比率<=0,返回10,否则返回如果负债比率>0AND负债比率<10,返回9,否则返回如果负债比率>10AND负债比率<=20,返回8,否则返回如果负债比率>20AND负债比率<=30,返回7,否则返回如果负债比率>30AND负债比率<=40,返回6,否则返回如果负债比率>40AND负债比率<=50,返回5,否则返回I
存货周转率评分赋值:如果存货周转率>=80,返回5,否则返回如果存货周转率<80AND存货周转率>=60,返回4,否则返回如果存货周转率<60AND存货周转率>=40,返回3,否则返回如果存货周转率<40AND存货周转率>=20,返回2,否则返回如果存货周转率<20AND存货周转率>=0,返回1,否则返回0
资产周转率评分赋值:如果固定资产周转率>=20,返回5,否则返回如果固定资产周转率<20AND固定资产周转率>=15,返回4,否则返回如果固定资产周转率<15AND固定资产周转率>=10,返回3,否则返回如果固定资产周转率<10AND固定资产周转率>=5,返回2,否则返回如果固定资产周转率<5AND固定资,返回?,否则返回?
估值评分赋值:市盈率评分+市净率评分+每股收益评分,画红色,NODRAW
收益评分赋值:资产报酬率评分+股本报酬率评分+净值报酬率评分+营业纯益率评分+主营利润率评分,NODRAW
资产评分赋值:负债比率评分+存货周转率评分+资产周转率评分,画黄色,NODRAW
当满足条件是否最后一个周期时,在横轴0.55纵轴0.26位置书写文字,画淡红色
当满足条件是否最后一个周期时,在横轴0.55纵轴0.36位置书写文字,画淡红色
当满足条件是否最后一个周期时,在横轴0.55纵轴0.46位置书写文字,画淡红色
评分赋值:估值评分+收益评分+资产评分
当满足条件是否最后一个周期时,在横轴0.55纵轴0.56位置书写文字,画红色
当满足条件是否最后一个周期时,在横轴0.55纵轴0.66位置书写文字,画红色
当满足条件1时,在横轴0.75纵轴0.76位置书写文字,画红色
当满足条件1时,在横轴0.78纵轴0.85位置书写文字,画红色
当满足条件1时,在横轴0.75纵轴0.10位置书写文字,画红色

爱查 股网 www.ai chagu.com

股票公式推荐
在线查股
个股查股导航:股票行情查询 DDX在线查询 超赢数据查询 资金流向 千股千评 个股最新消息 大小非解禁 十大股东查询 分红配股查询 业绩预告查询
丰原药业 000153+6.42% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
通策医疗 600763+6.39% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
芯瑞达 002983+6.28% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
新通联 603022+6.21% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
天瑞仪器 300165+6.19% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
荃银高科 300087+6.05% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
易华录 300212+6.03% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
雪榕生物 300511+5.99% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
奥特佳 002239+5.90% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
哈工智能 000584+5.84% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
商务合作:在线客服
爱查股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。粤ICP备17111814号-1
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)