爱查股网 www.aichagu.com 股票查询最好股票网 个股数据查询好股网 关闭本站广告
爱查股网
股票查询最好股票网 个股数据查询好股网
您的位置:爱查股网 > 股票公式 > 同花顺公式
股票公式搜索:

同花顺改进的威廉指标公式

2020/7/21 18:31:08

威廉波段:=100-(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100;
威廉风险:=IF(威廉波段>95,95,110),COLOR00FFFF,LINETHICK0;
DRAWBAND(110,RGB(0,250,250),威廉风险,RGB(0,0,0));
威廉顶部:威廉风险,COLORFF0000,LINETHICK2;
WLDB:=IF(威廉波段<5,15,-10),COLORFFFF00,LINETHICK1;
DRAWBAND(WLDB,RGB(250,250,0),-10,RGB(0,0,0));
威廉底部:WLDB,COLORFF0000,LINETHICK2;
N:=3;
VAR01:=MA(HHV(HIGH,485),17);
VAR02:=MA(HHV(HIGH,222),17);
VAR03:=MA(HHV(HIGH,96),17);
VAR04:=MA(LLV(LOW,485),17);
VAR05:=MA(LLV(LOW,222),17);
VAR06:=MA(LLV(LOW,96),17);
VAR07:=MA((VAR04*0.96+VAR05*0.96+VAR06*0.96+VAR01*0.558+VAR02*0.558+VAR03*0.558)/6,17);
VAR08:=MA((VAR04*1.25+VAR05*1.23+VAR06*1.2+VAR01*0.55+VAR02*0.55+VAR03*0.65)/6,17);
VAR09:=MA((VAR04*1.3+VAR05*1.3+VAR06*1.3+VAR01*0.68+VAR02*0.68+VAR03*0.68)/6,17);
VAR10:=MA((VAR07*3+VAR08*2+VAR09)/6*1.738,17);
VAR11:=IF(DATE<=1050531,VAR10,VAR10*DAY);
VAR12:=LOW;
VAR13:=REF(LOW,1);
VAR14:=SMA(ABS(VAR12-VAR13),3,1)/SMA(MAX(VAR12-VAR13,0),N,1)*100;
VAR15:=MA(IF(CLOSE*1.35<=VAR11,VAR14*10,VAR14/10),N);
VAR16:=LLV(LOW,30);
VAR17:=HHV(VAR15,30);
VAR18:=1990831;
VAR19:=IF(DATE<=VAR18,MA(IF(LOW<=VAR16,(VAR15+VAR17*2)/2,0),N),100000000);
VAR20:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*100;
VAR21:=SMA(VAR20,3,1);
VAR22:=SMA(VAR21,3,1);
VAR23:=3*VAR21-2*VAR22;
VAR24:=IF(VAR23>=100,100,IF(VAR23<=0,0,VAR23));
VAR36:=100-((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17))));
VAR37:=100-(MA(((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17)))),4));
VAR38:=MA(VAR37,1);
VAR39:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MC:=IF((VAR24=0),100,110);
DRAWBAND(110,RGB(240,240,0),MC,RGB(0,0,0));
卖出:MC,COLORFF00FF,LINETHICK2;
超低:=IF(VAR19>30000 AND VAR19>30000,20,-10);
DRAWBAND(超低,RGB(250,180,0),-10,RGB(0,0,0));
超低A:超低,COLOR0000FF,LINETHICK2;
CD:=IF(VAR39<5,10,-10);
DRAWBAND(CD,RGB(180,0,0),-10,RGB(0,0,0));
抄底:CD,COLOR00FFFF,LINETHICK2;
DB:IF(VAR19>10000 AND VAR19>20000,0,-10);
DRAWBAND(DB,RGB(240,0,250),-10,RGB(0,0,0));
锯齿底部:DB,COLORFFFF00,LINETHICK2;
超短:IF((VAR36<VAR38),VAR38,VAR36),COLORFF00FF,LINETHICK2;
走势:(VAR38),COLORFF0000,LINETHICK2;
DRAWBAND(超短,RGB(250,110,0),走势,RGB(0,250,0));
威廉:威廉波段,COLORCCCC00,LINETHICK2;
STICKLINE(1,80,80,2,0),COLORFFFF00;
STICKLINE(1,50,50,2,0),COLORFF0000;
STICKLINE(1,20,20,2,0),COLOR0000FF;

股票公式推荐
在线查股
商务合作:在线客服
爱查股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。粤ICP备17111814号-1
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)