爱查股网 www.aichagu.com 股票查询最好股票网 个股数据查询好股网 关闭本站广告
爱查股网
股票查询最好股票网 个股数据查询好股网
您的位置:爱查股网 > 股票公式 > 通达信公式
股票公式搜索:

通达信六组趋势线主图指标公式

2020/1/10 7:18:14

{颈线}
周期:=5;
QA短:=REF(H,周期)=HHV(H,2*周期+1);
QB短:=BACKSET(QA短,周期+1);
QC短:=FILTER(QB短,周期) AND H=HHV(H,周期+1);
QD短:=BARSLAST(QC短);
QE短:=IF(QC短,CURRBARSCOUNT,0);
QF短:=IF(QD短,REF(QE短,QD短),QE短);
QG短:=CONST(QF短),NODRAW;
QH短:=REF(QF短,QD短+1);
QW短:=CONST(QH短),NODRAW;
NOTEXT短长压:DRAWLINE(CURRBARSCOUNT=QW短,H,CURRBARSCOUNT=QG短,H,1),COLORGREEN;
NOTEXT短长远高:DRAWLINE(CURRBARSCOUNT=QW短,H,ISLASTBAR,REF(H,QW短-1),1),COLORGREEN,DOTLINE;
NOTEXT短长近高:DRAWLINE(CURRBARSCOUNT=QG短,H,ISLASTBAR,REF(H,QG短-1),1),COLORGREEN,DOTLINE;
TPD短长期:=DRAWLINE(CURRBARSCOUNT=QW短,H,CURRBARSCOUNT=QG短,H,1);
DRAWICON(REF(C,1)TPD短长期 AND REF(TPD短长期,1)>TPD短长期,L*0.98,1);
QA中:=REF(H,周期*2)=HHV(H,2*周期*2+1);
QB中:=BACKSET(QA中,周期*2+1);
QC中:=FILTER(QB中,周期*2) AND H=HHV(H,周期*2+1);
QD中:=BARSLAST(QC中);
QE中:=IF(QC中,CURRBARSCOUNT,0);
QF中:=IF(QD中,REF(QE中,QD中),QE中);
QG中:=CONST(QF中);
QH中:=REF(QF中,QD中+1);
QW中:=CONST(QH中);
DRAWLINE(CURRBARSCOUNT=QW中,H,CURRBARSCOUNT=QG中,H,1),COLORGREEN;
DRAWLINE(CURRBARSCOUNT=QW中,H,ISLASTBAR,REF(H,QW中-1),1),COLORGREEN,DOTLINE;
DRAWLINE(CURRBARSCOUNT=QG中,H,ISLASTBAR,REF(H,QG中-1),1),COLORGREEN,DOTLINE;
TPD中长期:=DRAWLINE(CURRBARSCOUNT=QW中,H,CURRBARSCOUNT=QG中,H,1);
DRAWICON(REF(C,1)TPD中长期 AND REF(TPD中长期,1)>TPD中长期,L*0.98,1);
QA长:=REF(H,3*周期)=HHV(H,2*3*周期+1);
QB长:=BACKSET(QA长,3*周期+1);
QC长:=FILTER(QB长,3*周期) AND H=HHV(H,3*周期+1);
QD长:=BARSLAST(QC长);
QE长:=IF(QC长,CURRBARSCOUNT,0);
QF长:=IF(QD长,REF(QE长,QD长),QE长);
QG长:=CONST(QF长),NODRAW;
QH长:=REF(QF长,QD长+1);
QW长:=CONST(QH长),NODRAW;
{WWW.aichagu.com 爱查股}
NOTEXT长长压:DRAWLINE(CURRBARSCOUNT=QW长,H,CURRBARSCOUNT=QG长,H,1),COLORGREEN;
NOTEXT长长远高:DRAWLINE(CURRBARSCOUNT=QW长,H,ISLASTBAR,REF(H,QW长-1),1),COLORGREEN,DOTLINE;
NOTEXT长长近高:DRAWLINE(CURRBARSCOUNT=QG长,H,ISLASTBAR,REF(H,QG长-1),1),COLORGREEN,DOTLINE;
TPD长长期:=DRAWLINE(CURRBARSCOUNT=QW长,H,CURRBARSCOUNT=QG长,H,1);
DRAWICON(REF(C,1)TPD长长期 AND REF(TPD长长期,1)>TPD长长期,L*0.98,1);
QA久:=REF(H,4*周期)=HHV(H,2*4*周期+1);
QB久:=BACKSET(QA久,4*周期+1);
QC久:=FILTER(QB久,4*周期) AND H=HHV(H,4*周期+1);
QD久:=BARSLAST(QC久);
QE久:=IF(QC久,CURRBARSCOUNT,0);
QF久:=IF(QD久,REF(QE久,QD久),QE久);
QG久:=CONST(QF久),NODRAW;
QH久:=REF(QF久,QD久+1);
QW久:=CONST(QH久),NODRAW;
NOTEXT久压:DRAWLINE(CURRBARSCOUNT=QW久,H,CURRBARSCOUNT=QG久,H,1),COLORGREEN;
NOTEXT久远高:DRAWLINE(CURRBARSCOUNT=QW久,H,ISLASTBAR,REF(H,QW久-1),1),COLORGREEN,DOTLINE;
NOTEXT久近高:DRAWLINE(CURRBARSCOUNT=QG久,H,ISLASTBAR,REF(H,QG久-1),1),COLORGREEN,DOTLINE;
TPD久期:=DRAWLINE(CURRBARSCOUNT=QW久,H,CURRBARSCOUNT=QG久,H,1);
DRAWICON(REF(C,1)TPD久期 AND REF(TPD久期,1)>TPD久期,L*0.98,1);
QAA短:=REF(L,周期)=LLV(L,2*周期+1);
QBB短:=BACKSET(QAA短,周期+1);
QCC短:=FILTER(QBB短,周期) AND L=LLV(L,周期+1);
QDD短:=BARSLAST(QCC短);
QEE短:=IF(QCC短,CURRBARSCOUNT,0);
QFF短:=IF(QDD短,REF(L,QDD短),L);
QGG短:=IF(QDD短,REF(QEE短,QDD短),QEE短);
QHH短:=CONST(QGG短);
QWW短:=REF(QFF短,QDD短+1);
QMM短:=REF(QGG短,QDD短+1);
QRR短:=CONST(QMM短);
NOTEXT短长支:DRAWLINE(CURRBARSCOUNT=QRR短,L,CURRBARSCOUNT=QHH短,L,1),COLORYELLOW;
NOTEXT短长近低:DRAWLINE(CURRBARSCOUNT=QHH短,L,ISLASTBAR,REF(L,QHH短-1),1),COLORYELLOW,DOTLINE;
NOTEXT短长远低:DRAWLINE(CURRBARSCOUNT=QRR短,L,ISLASTBAR,REF(L,QRR短-1),1),COLORYELLOW,DOTLINE;
QAA中:=REF(L,周期*2)=LLV(L,2*周期*2+1);
QBB中:=BACKSET(QAA中,周期*2+1);
QCC中:=FILTER(QBB中,周期*2) AND L=LLV(L,周期*2+1);
QDD中:=BARSLAST(QCC中);
QEE中:=IF(QCC中,CURRBARSCOUNT,0);
QFF中:=IF(QDD中,REF(L,QDD中),L);
QGG中:=IF(QDD中,REF(QEE中,QDD中),QEE中);
QHH中:=CONST(QGG中);
QWW中:=REF(QFF中,QDD中+1);
QMM中:=REF(QGG中,QDD中+1);
QRR中:=CONST(QMM中);
NOTEXT中长支:DRAWLINE(CURRBARSCOUNT=QRR中,L,CURRBARSCOUNT=QHH中,L,1),COLORYELLOW;
NOTEXT中长近低:DRAWLINE(CURRBARSCOUNT=QHH中,L,ISLASTBAR,REF(L,QHH中-1),1),COLORYELLOW,DOTLINE;
NOTEXT中长远低:DRAWLINE(CURRBARSCOUNT=QRR中,L,ISLASTBAR,REF(L,QRR中-1),1),COLORYELLOW,DOTLINE;
QAA长:=REF(L,周期*3)=LLV(L,2*周期*3+1);
QBB长:=BACKSET(QAA长,周期*3+1);
QCC长:=FILTER(QBB长,周期*3) AND L=LLV(L,周期*3+1);
QDD长:=BARSLAST(QCC长);
QEE长:=IF(QCC长,CURRBARSCOUNT,0);
QFF长:=IF(QDD长,REF(L,QDD长),L);
QGG长:=IF(QDD长,REF(QEE长,QDD长),QEE长);
QHH长:=CONST(QGG长);
QWW长:=REF(QFF长,QDD长+1);
QMM长:=REF(QGG长,QDD长+1);
QRR长:=CONST(QMM长);
NOTEXT长长支:DRAWLINE(CURRBARSCOUNT=QRR长,L,CURRBARSCOUNT=QHH长,L,1),COLORYELLOW;
NOTEXT长长近低:DRAWLINE(CURRBARSCOUNT=QHH长,L,ISLASTBAR,REF(L,QHH长-1),1),COLORYELLOW,DOTLINE;
NOTEXT长长远低:DRAWLINE(CURRBARSCOUNT=QRR长,L,ISLASTBAR,REF(L,QRR长-1),1),COLORYELLOW,DOTLINE;
{2画K线}
STICKLINE(C=O,C,O,2,1),COLORWHITE;
STICKLINE(C=O,H,L,0,0),COLORWHITE;
STICKLINE(C>O,C,O,2,1),COLORLIRED;
STICKLINE(C>O,H,MAX(O,C),0,0),COLORLIRED;
STICKLINE(C>O,L,MIN(O,C),0,0),COLORLIRED;
STICKLINE(CSTICKLINE(CSTICKLINE(CEMA13:=EMA(C,13),NODRAW;
ZR:=TFILTER(C<=EMA13 AND REF(C,1)>EMA13,C>EMA13,1);
ZQ:=TFILTER(C>EMA13 AND REF(C,1)<=EMA13,C<=EMA13,1);
转强周期:=BARSLAST(ZQ),NODRAW;
转弱周期:=BARSLAST(ZR),NODRAW;
STICKLINE(ZR,H,L,0,0),COLORFFF370;
STICKLINE(ZR,O,C,2,0),COLORFFF370;
STICKLINE(ZQ,H,L,0,0),COLORMAGENTA;
STICKLINE(ZQ,O,C,2,0),COLORMAGENTA;
ZT1:=C/REF(C,1)>1.097;
BH1:=BARSLAST(ZT1);
STICKLINE(ZT1,REF(O,BH1),REF(C,BH1),2,0),COLORYELLOW;
STICKLINE(ZT1,REF(H,BH1),REF(L,BH1),0,0),COLORYELLOW;

通达信六组趋势线主图指标公式的选股公式

股票公式推荐
在线查股
商务合作:在线客服
爱查股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。粤ICP备17111814号-1
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)