爱查股网 www.aichagu.com 股票查询最好股票网 个股数据查询好股网 手机访问本页
| 保存本站网址 | 关闭站内广告
爱查股网
股票查询最好股票网 个股数据查询好股网
您的位置:爱查股网 > 股票公式 > 大智慧公式
股票行情查询:

大智慧KDJ量主图指标公式

2019/1/21 21:39:47

Var2:=LLV(LOW,5);
Var3:=HHV(HIGH,5);
K:EMA((CLOSE-Var2)/(Var3-Var2)*100,4),COLORFFFFFF,linethick0;
D:EMA(0.667*REF(K,1)+0.333*K,2),COLOR00FFFF,linethick0;
J:3*K-2*D,COLORFF50FF,linethick0;
hhZ:=HHV(ref(HIGH,1),5);
llZ:=LLV(ref(LOW,1),5);
jc:=ema((hhZ+llZ)/2,5);
bl:=(CLOSE-LLZ)/(HHZ-LLZ);
kz:IF(BARSSINCE(C)<1,C,ema(jc*(1+(BL-0.5)/5),4)),COLORFFFFFF,linethick0;
dz:IF(BARSSINCE(C)<1,C,ema(jc*(eMA(BL,4)-0.5)/5+jc,4)),COLOR00FFFF,linethick0;
jz:IF(BARSSINCE(C)<1,C,3*kz-2*dz),COLORFF50FF,linethick0;
POLYLINE(kz,kz),COLORFFFFFF;
POLYLINE(dz,dz),COLOR00FFFF;
POLYLINE(jz,jz);
角度:atan((kz-ref(kz,1))/abs(ref(kz,1))*100)*180/3.1416,linethick0;
DRAWTEXTABS(2,5,'所属板块:'+BKNAME),COLORFF50FF,linethick1;
总股本:=FINANCE2(35)/1000000*100;流通盘:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(15,20,'总股本:'+NUMTOSTRN(总股本,2)+'亿'),LINETHICK1,COLORFFFFFF;
DRAWTEXTABS(15,35,'流通盘:'+NUMTOSTRN(流通盘,2)+'亿'),LINETHICK1,COLORFFFFFF;
每股收益:=FINANCE2(3);
换手率0:=vol/capital*100;
DRAWTEXTABS(15,50,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),LINETHICK1,COLORFFFFFF;
X1:=IF(PFFIN(4003,0)>5,1,0);
X2:=IF(PFFIN(4013,0)>5,1,0);
X3:=IF(PFFIN(4023,0)>5,1,0);
X4:=IF(PFFIN(4033,0)>5,1,0);
X5:=IF(PFFIN(4043,0)>5,1,0);
ZX:=PFFIN(4002,0)*X1+PFFIN(4012,0)*X2+PFFIN(4022,0)*X3+PFFIN(4032,0)*X4+PFFIN(4042,0)*X5;
真换手率:=vol/(capital-ZX/100)*100;
真流通股:=(capital-ZX/100)/1000000;
DRAWTEXTABS(15,80,'真换手率:'+NUMTOSTRN(真换手率,2)+'%'),LINETHICK1,COLORYELLOW;
DRAWTEXTABS(15,95,'真流通盘:'+NUMTOSTRN(真流通股,2)+'亿'),LINETHICK1,COLORYELLOW;
A:=ALL(jz>ref(jz,1),2);
B:=kz<=ref(kz,1);
换手率:VOL/CAPITAL*100,COLORRED,LINETHICK0;
量:=VOL;
Ad:=LLVALL(L)*0.95;
Bd:=(LLVALL(L)*1.1-Ad)/HHVALL(量)*0.5;
STICKLINE(jz>ref(jz,1),Ad,Ad+量*Bd,6,0),COLORRED;
STICKLINE(jz<=ref(jz,1),Ad,Ad+量*Bd,6,0),COLORGREEN;
MAV3:=Ad+MA(量,3)*Bd;
MAV8:=Ad+MA(量,8)*Bd;
POLYLINE(MAV3,MAV3),COLORFF00FF;
POLYLINE(MAV8,MAV8),COLORYELLOW;
stickline(c>1.097*ref(c,1) and C=H,O+(C-O)/2,c,5,0),color00DDFF,LAYER7;
stickline(c<0.901*ref(c,1) and C=L,C,C+(O-C)/2,7,0),ColorFF0000,LAYER7;
DRAWTEXTABS(500,5,' KDJ+量主图'),COLORred,linethick5;
DRAWGBKLAST(c>0,STRIP(RGB(10,60,0),RGB(50,10,0),0));

股票公式推荐
在线查股
个股查股导航:股票行情查询 DDX在线查询 超赢数据查询 资金流向 千股千评 个股最新消息 大小非解禁 十大股东查询 分红配股查询 业绩预告查询
蓝光发展 600466+3.51% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
康盛股份 002418+3.49% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
永清环保 300187+3.46% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
川大智胜 002253+3.46% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
骆驼股份 601311+3.46% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
华灿光电 300323+3.45% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
一拖股份 601038+3.45% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
锦江股份 600754+3.44% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
沃华医药 002107+3.43% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
梅雁吉祥 600868+3.40% 千股千评 DDX指标 超赢 资金流向 大小非 股东 分红
商务合作:在线客服
爱查股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。粤ICP备17111814号-1
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)